Apr 062009
 

ubuntulogo_smallHo da poco (beh, in realtà con Linux ci gioco da parecchio tempo) installato l’ultima versione disponibile di Ubuntu (la 8.10 “Intrepid Ibex”) ed ho pensato di appuntarmi qui alcune problematiche (e relative soluzioni) a cui sono andato incontro, in modo da facilitare me in una successiva installazione (e tutti quelli che hanno incontrato lo stesso problema).

1. Installare Flash Player 10
Semplice: basta scaricare questo pacchetto ed installarlo con un normale doppio click, come se fosse un’applicazione Windows.

2. Assegnazione IP statico ad un’interfaccia di rete
Questa è stata un po’ più dura: ho provato ad assegnare un IP statico alla scheda di rete tramite Network Manager, ma al riavvio la configurazione era tornata su Automatico (DHCP). Cercando in rete ho scoperto che è un bug riconosciuto del Network Manager, e quindi dopo aver provato ad assegnare un IP statico ad una nuova connessione (con lo stesso MAC Address della vecchia, workaround comunque funzionante), per evitare ulteriori problemi ho disinstallato Network Manager:

sudo apt-get remove network-manager network-manager-gnome

Ho riavviato la macchina, e successivamente ho configurato manualmente l’interfaccia di rete:

sudo gedit /etc/networks/interfaces

auto eth0
iface eth0 inet static
address xxx.xxx.xxx.xxx
netmask xxx.xxx.xxx.xxx
gateway xxx.xxx.xxx.xxx

Quindi ho modificato il file di configurazione dei DNS:

sudo gedit /etc/resolv.conf

nameserver xxx.xxx.xxx.xxx

Riavviato il networking per rendere effettive le modifica:

sudo /etc/init.d/networking restart

… e come per magia, tutto ha iniziato a funzionare come volevo io… 😉

3. Abilitare driver proprietari per la scheda video
Semplice: il sistema rileverà se esistono driver proprietari per la scheda video in uso, e vi chiederà se avete problemi “etici” nell’usarli (magari siete maniaci dell’Open Source e tutto quello che è proprietario vi fa schifo); io personalmente li ho attivati subito… 😛

4. Aggiornare OpenOffice da 2.4 a 3.0
La versione di OpenOffice installata di default con Ubuntu 8.10 è la 2.4, mentre è disponibile la 3.0. Per installarla facilmente, sovrascrivendo la versione precedente, fate così:

Aggiornate il file sources.list aggiungendo i repository di Launchpad:

sudo gedit /etc/apt/sources.list ed inserite dove volete queste due righe:

deb http://ppa.launchpad.net/openoffice-pkgs/ubuntu intrepid main
deb-src http://ppa.launchpad.net/openoffice-pkgs/ubuntu intrepid main

aggiornate la lista dei pacchetti disponibili con

sudo apt-get update
sudo apt-get upgrade

andate in Synaptic e marcate per l’aggiornamento OpenOffice. Fatto! 😉

5. Installare codec Divx/XviD
Semplice: cercate di aprire un file video codificato in DivX o XviD: Totem (player predefinito) cercherà i codec adatti (Gstreamer plugin) e vi chiederà di installarli. Fatelo… e potrete godervi i vostri video in Ubuntu.

6. Mostrare sul desktop le icone Cestino, Home, Computer e Rete
Vecchio retaggio del mondo Windows, quelle icone sono le uniche che voglio avere sul desktop (beh, sul desktop Windows ho anche le icone per l’accesso RDP ai vari server).
Aprite una finestra di terminale e digitate:

gconf-editor

Nell’editor di configurazione, navigate l’albero fino a raggiungere la posizione apps\nautilus\desktop e spuntate le voci che volete visualizzare sul desktop (computer_icon_visible, home_icon_visible, network_icon_visible, trash_icon_visible).

7. Installare Skype
Ci sono due strade disponibili per installare Skype: la prima è scaricare il pacchetto apposito dal sito di Skype (e che probabilmente richiederà il download di diverse altre librerie), la seconda è di aggiugnere il repository dove c’è Skype ed installarlo da riga di comando. Ho scelto questa seconda strada… 😛

Aggiungete il repository di Skype:

sudo gedit /etc/apt/sources.list ed inserite dove volete questa riga:

deb http://download.skype.com/linux/repos/debian/ stable non-free

Diamo una rinfrescata:

sudo apt-get update

ed infine installiamo Skype:

sudo apt-get install skype

Done! 😉

8. Installare Gnome Network Manager
Ubuntu 8.10 non installa di default l’applet di gestione network (in cui potete modificare graficamente l’hostname, il gruppo di lavoro, gli indirizzi IP ecc).
Per installarla, digitare da terminale:

sudo apt-get install gnome-network-admin

9. Elevare i privilegi di un utente
Dopo aver “penato” un po’ per riuscire a far joinare la mia macchina Ubuntu ad un dominio Active Directory (niente di trascendentale, per carità… ma sarà oggetto di un post separato) mi si è presentato il problema che l’utente in questione NON poteva utilizzare sudo o gestire alcunchè. Fatto le dovute ricerche in rete, mi è bastato aggiungere l’utente in questione al gruppo ADMIN (loggandomi come utente locale e non di dominio), con:

sudo adduser utente@dominio admin

L’utente del dominio Active Directory è immediatamente diventato capace di usare sudo e lanciare operazioni amministrative.

  44 Responses to “Problem solving su installazione Ubuntu 8.10 “Intrepid Ibex””

  1. ho provato ad assegnare un IP statico alla scheda di rete tramite Network Manager, ma al riavvio la configurazione era tornata su Automatico (DHCP)

    Uhu? Controllato se succede anche ad altri? Se sì è un bel bug e segnalarlo non sarebbe male.

    PS: io son fermo sul desktop alla 7.04. Non ce la fa il catorcio datato 2001 ad andare oltre 😀
    Però è configurato a mia immagine e somiglianza ^_^

  2. ho provato ad assegnare un IP statico alla scheda di rete tramite Network Manager, ma al riavvio la configurazione era tornata su Automatico (DHCP)

    Uhu? Controllato se succede anche ad altri? Se sì è un bel bug e segnalarlo non sarebbe male.

    PS: io son fermo sul desktop alla 7.04. Non ce la fa il catorcio datato 2001 ad andare oltre 😀
    Però è configurato a mia immagine e somiglianza ^_^

    • Eh si, Donzo caro… è un bug riconosciuto, basta fare una ricerca per "ubuntu 8.10 network manager static address" ed ottieni una valanga di risultati… 🙂
      Speriamo l'abbiano fissato nella 9.04 di prossima uscita…. 🙂

  3. ho provato ad assegnare un IP statico alla scheda di rete tramite Network Manager, ma al riavvio la configurazione era tornata su Automatico (DHCP)

    Uhu? Controllato se succede anche ad altri? Se sì è un bel bug e segnalarlo non sarebbe male.

    PS: io son fermo sul desktop alla 7.04. Non ce la fa il catorcio datato 2001 ad andare oltre 😀
    Però è configurato a mia immagine e somiglianza ^_^

  4. Io purtroppo ho un problema più "radicale".. :S
    Non riesco a far partire Ubuntu sul mio HP Compaq nx9005, vecchiotto e perfetto per Linux…

    E' un problema hardware, probabilmente la scheda video non è supportata perché freeza durante il caricamento (sia live cd che installazione)… 🙁

  5. @ Lorenzo: installazione in modalità grafica sicura. Carica dei driver video minimali. Ora ti prego non chiedermi esattamente come perchè non ho un cd qui con me, ma all'avvio da live cd c'è l'opzione premendo uno dei tasti funzione della tastiera.

    Installa tutto e alla scheda video ci penserai dopo

  6. ciao Giovy,
    quando hai installato ubuntu,
    che tipo di file system hai impostato nella formattazione?

  7. […] post originale lo trovi qui…: Problem solving su installazione Ubuntu 8.10 “Intrepid Ibex” Share and […]

  8. Ah ecco perchè il router non mi apriva le porte. Piccolo typo: dimenticata una "f" su /etc/resolv.conf

  9. Oooooh… finalmente cominciamo a rivolgerci a qualche OS serio… 😀 bravo Gio, sono fiera di te!! 😀

    • Ahaha… ma guarda che se vai indietro di anni, troverai miei post su Fedora, Suse ecc… Mica sono "nuovo" al mondo Linux… 🙂

  10. Quoto Nicola, ext3… 🙂

  11. Usabilità di Linux: devi editare 4 o 5 files di configurazione per fare ogni minima ca**ata. 🙂

    • Discutibile qualunquismo.
      Non mi piacciono i confronti, ma per esempio, hai visto cosa bisogna fare per ripristinare l'icona del cestino su Vista?

      Il buon google ti chiarirà 🙂

      • Non che mi freghi (sto su MacOS da un annetto) ma non paragonarmi l'usabilità della più schifosa versione di Windows a quella della migliore distro Linux. C'è comunque un bel distacco a favore di Windows.

        (parlo di utente medio-basso eh, non di utente avanzato)

        Linux su desktop non sfonderà mai.
        http://www.napolux.com/2008/cari-linux-user.html

        Ovviamente sto alla finestra per vedere se (come dicono) ci sarà una versione di Android per Netbook. Nel frattempo mi "godo" OSX e Vista quando non ho il macbook sottomano.

  12. @donzo e giovy: ho provato anche in modalità grafica sicura… nada… è un problema con l'ACPI:
    https://bugs.launchpad.net/ubuntu/+source/linux-s

    Ho provato a digitare F6 e partire con un "acpi=off no lapic"… ma uguale.. 🙁

  13. ciao Giovy,
    volevo solo chiederti quale tipo di file system hai impostato durante la formattazione,
    non voglio sapere dagli altri qual'è il tipo migliore da impostare,
    grazie!
    😀

  14. Max, ti ho risposto primo: ext3… 🙂

  15. @lorenzo_raffio
    non so se può essere la causa, ma io ho risolto il mio problema con ubuntu ed un vecchio portatile [1] così:
    -L'ho installato via command line (alternate cd), rebootato in "recovery mode" da grub e ottenuto la shell di root. Ho poi modificato /etc/X11/xorg.conf aggiungendo nella sezione "Device"
    Driver "trident" [quello che serve a me]
    Option "NoDDC" [la vera soluzione al problema… per schede vecchie che, a quanto ho capito googlando, non supporto il probe hw all'avvio di X]

    così mi funziona….

    [1] toshiba 1800-400, driver video "trident"; sia da livecd che post installazione (sia grafica che command line via alternate cd), schermo nero appena provava a far partire X.

  16. non so se il driver è "Radeon" o "ati" o "antani" 🙂
    prova in primis a mettere solo la riga di Option; se poi non funziona, googla un po' per capire il nome del diver e inserisci pure quello.
    Se poi mi dici che funziona, si aggiungerà al tracker!

  17. Uhm…. quindi scrivo "VESA" come driver..

  18. @lorenzo:
    dalle immagini (enormi… 🙂 che hai postato direi che:
    – usi troppi megapixel per degli screenshot 🙂
    – nel primo screenshot si parla anche di un bcm43xx che se non sbaglio a che vedere col wireless: probabilmente non c'entra nulla, ma prova anche a rimuoverla per fare il test su xorg
    – stai usando il driver VESA e non quello ati/radeon/antani

  19. @lorenzo:
    su bcm43xx, direi di sì…
    http://www.google.it/search?q=bcm43xx&ie=utf-
    su "VESA": io sinceramente proverei ad usare in primis il driver adatto alla tua scheda e non uno generico (come ho fatto io sul toshiba aggiungendo l'opzione che ti dicevo sopra). da quello che dice google [http://ubuntuforums.org/showthread.php?t=81547%5D sembra che tu debba provare ad usare il driver "ati" o "radeon" (non provare con "antani" :). il primo sembra il migliore. leggiti il thread comunque.

  20. Oook.. 🙂
    Ultima cosa.
    Sono riuscito ad installare kubuntu tramite wubi, quindi riesco a scegliere al boot quale sistema lanciare, ovviamente se lancio kubuntu mi rifa la stessa cosa.. però io posso accedere alla command-line digitando "c"..
    Quale comando devo usare per modificare xorg.conf?
    sudo gedit nano vi questi qua non fungono… :$

  21. [a memoria] dovresti lanciare kubuntu in "recovery mode", poi ottenere il root prompt e fare
    nano /etc/X11/xorg.conf

  22. @ Lorenzo: usa la procedura guidata

    sudo dpkg-reconfigure xserver-xorg

  23. Linux: bug come quello riscontrato da Giovy? Puoi editare a mano i file di sistema.
    OS X: stesso discorso o giù di lì (i file plist fanno miracoli)
    Windows: di solito formatti…

    Ti parlo da utente medio che usa giornalmente win, linux e os x.

    Per il resto che sfondi o meno a me poco importa, basta che quello che uso piaccia a me e vada incontro alle mie esigenze. Però linkare te stesso come fonte di un'affermazione tanto categorica, perdonami se ti faccio notare è un po' una barzelletta…

    PS: non apriamo guerre religiose sui byte! Volemose bene, è quasi Pasqua, abbiamo solo opinioni differenti… Che poi il padrone di casa ci sbatte fuori 😀

    • Linkato solo per esporre il mio punto di vista (che avevo già esposto in quel post) senza così dilungarmi troppo nei commenti, don't worry, non vengo mica a cercare visibilità qua 😉

      P.s.
      Niente guerre, punti di vista differenti. Buona Pasqua 😉

      • Eheheh… beh, fino a che non vi iniziate a prendere a parolacce, potete esprimere senza problemi anche punti di vista diversi, eh! 😀

  24. Fatto… ho provato sia con Driver: "Radeon" che "Ati" che "Vesa"… nada… 🙁

  25. Ricapitolando…
    Quando parto con Kubuntu mi si apre la schermata di login, tutto sembra ok, la tastiera funziona, scrivo normalmente (non va a scatti; a parte il mouse che non funge, ma vabbè…) inserisco i miei dati del login, parte e… rimane così… cioè si vede il desktop (solo l'immagine, senza icone/barre/niente) e rimane così per sempre (ieri l'ho lasciato 2 ore così…).
    Una cosa che mi ero dimenticato di dirvi.. dopo circa 10 minuti si sente il suono dell'avvio classico…però soo quello…

  26. mmmh, boh. ho finito le idee. 🙂
    il wireless l'hai staccato? da quello che descrivi X parte subito a bomba (cosa che in teoria ti dava problemi prima) e poi è gnome ad intortarsi. prova a staccare il wireless e attaccarlo via ethernet o lasciarlo direttamente non collegato.
    potrebbe essere network manager/gnome…

    • Ma staccare il wireless nel router o nel portatile? Se nell'ultimo… non ho idea di come fare.. è già integrato… nel bios non vedo alcuna opzione…

      Donzooooooooo :p

  27. [comunque abbiamo decisamente fatto un hijack del post di giovy…]
    mi riferivo al wireless del portatile: pensavo che fosse qualche schedina esterna. se è integrata, l'unica che mi viene in mente ora è di mettere il modulo in blacklist ma te lo sconsiglio se non sai cosa stai facendo… :/

  28. Molto utili le tue informazioni, alcune non le conoscevo!
    Anche io ho fatto un post dello stesso genere sul mio blog, appuntandomi le cose da fare dopo aver installato Ubuntu 8.10: http://mb.netsons.org/2009/02/10-cose-da-fare-dop

  29. […] Problem solving su installazione Ubuntu 8.10 “Intrepid Ibex” […]

  30. […] Problem solving su installazione Ubuntu 8.10 “Intrepid Ibex” […]

 Leave a Reply

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>

(required)

(required)